云狐网

您现在的位置是:首页 > 电脑之家 > 路由器

路由器

PPPOE拨号上网服务器端与客户端的完整配置

offoce66 2022-04-21 15:12:36路由器

我们现在所在的小区大部分还是通过PPPOE拨号方式来上网的,宽带服务提供商会在ISP机房搭建PPPOE服务器。vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

PPPOE拨号上网服务器端与客户端的完整配置

PPPOE即PPP over Ethernet,是指在以太网中传输PPP的技术,通过PPPoE可以防范ARP欺骗,同时为客户端统一分配IP以及DNS等参数,有效避免了静动态IP方式因地址冲突或者参数设置不当导致无法访问外网的问题,还可以结合Radius服务器对客户进行认证、授权以及计费,目前国内ISP多采用PPPoE作为接入认证方式。vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

今天我们演示一下,ISP运营商如何配置PPPOE服务器,以及我们上网的路由器如何配置PPPOE拨号登录PPPOE服务器上。vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

PPPOE拨号上网服务器端与客户端的完整配置vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网
一、配置运营商服务器端

运营商服务器需要配置如下内容:vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

<Huawei>system-viewvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[Huawei]sysname ISPvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

1创建地址池

地址池是分配给拨号用户的可使用的地址范围;vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP]ip pool 1vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-ip-pool-1]network 10.10.10.0 mask 24vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

PPPOE拨号上网服务器端与客户端的完整配置

[ISP-ip-pool-1]gateway-list 10.10.10.254vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-ip-pool-1]dns-list 114.114.114.114vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-ip-pool-1]qvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

PPPOE拨号上网服务器端与客户端的完整配置vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网
2创建AAA认证

[ISP]aaavjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

创建用户PPPOE用户名为:1802079,密码为:huaweivjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-aaa]local-user 1802099 password cipher huaweivjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-aaa]local-user 1802099 service-type ppp //配置服务类型为PPPvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

若有多个客户端需要登录到PPPOE服务器上,需要创建多个用户;vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-aaa]qvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

3创建虚拟模板VT接口

VT模板就是为了让一条链路上可以封装多种同层协议的虚拟接口。因为现在的以太网物理接口已经默认封装了以太网协议,无法再封装其他的wan协议了,所以才需要vt来模拟一个(WAN)ppp接口,然后封装其他协议如ppp,最后再把vt绑定到物理接口,实现ppp和以太网协议的嵌套。vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP]interface Virtual-Template 1vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-Virtual-Template1]ppp authentication-mode pap //定义PPP采用PAP方式认证,还有Chap认证;vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-Virtual-Template1]remote address pool 1 //指定远端用户地址池;vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-Virtual-Template1]ip address 10.10.10.1 24 //配置本地VT的地址,需与客户端地址池在同一网段,不然用户无法上线。vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-Virtual-Template1]qvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

4启用PPPOE功能

[ISP]interface GigabitEthernet 0/0/0vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-GigabitEthernet0/0/0]pppoe-server bind virtual-template 1//在接口下绑定虚拟认证模板;vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-GigabitEthernet0/0/0]qvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP]vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

配置完成后,这样vt虚拟接口和连接pppoe客户端的物理以太网接口绑定,完成pppoe协议的封装。vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

5配置回环口,用来测试

[ISP]interface LoopBack 0vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-LoopBack0]ip address 2.2.2.2 32vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP-LoopBack0]qvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[ISP]vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

二、用户客户端配置

<Huawei>system-viewvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[Huawei]sysname R2vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

1创建规则,定义允许所有IP

[R2]dialer-rulevjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-dialer-rule]dialer-rule 1 ip permitvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-dialer-rule]qvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

2配置拨号1

[R2]interface Dialer 1vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-Dialer1]link-protocol ppp //封装PPP协议vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

3创建客户端拨号用户名和密码

[R2-Dialer1]ppp pap local-user 1802099 password cipher huaweivjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-Dialer1]ip address ppp-negotiate //配置PPPOE客户端自动获取IP地址;vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-Dialer1]dialer timer idle 300//设置按需pppoe拨号的空闲时间(300s没有流量就断开)vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-Dialer1]dialer timer autodial 5 //重拨时间vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-Dialer1]dialer user user1//指定dialer接口拨号所使用的用户,与PPP认证用户一致;vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

PPPOE拨号上网服务器端与客户端的完整配置

这里的用户名和密码为ISP服务器上建立的用户名;vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

4关联物理口

[R2-Dialer1]dialer bundle 1vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

5管理Rule 1

[R2-Dialer1]dialer-group 1vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-Dialer1]qvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

6物理接口建立PPPOE会话

[R2]interface GigabitEthernet 0/0/0vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-GigabitEthernet0/0/0]pppoe-client dial-bundle-number 1vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

//这里的1要和第一步的拨号口 1对应;vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-GigabitEthernet0/0/0]mtu 1492//修改mtu=1492Bytevjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2-GigabitEthernet0/0/0]qvjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

[R2]vjb电脑_数码_手机应用问题解决的IT技术网站seo - 云狐网

 1/2    1 2 下一页 尾页